Logo

Firefox: Instalar extensiones o add-on incompatibles en última versión

Firefox en un navegador web que constantemente se está actualizando y mejorando. Pero como todo tiene un precio, los usuarios muchas veces al actualizar a la última versión nos encontramos con sorpresas inesperadas, entre ellas nuestra extensión o add-on dejan de funcionar por incompatibilidad.

Este problema de incompatibilidad tiene solución y es posible instalar la extensión incompatible en la última versión de Firefox (actualmente 3.5) “Incompatible Extension
firefox-add-on-install-35-1xie

Pasos para instalar Add-on incompatibles:
- Descargar la última versión del add-on incompatible (.xpi), posiblemente ubicado en el botón “See All Versions” de la página oficial de Firefox. Usar algún gestor de descarga
- Descomprimir el archivo .xpi con WinRAR o algún otro programa semejante
- En la carpeta donde se haya descomprimido el archivo .xpi buscar el archivo install.rdf y abrirlo con el block de notas o algún otro editor de texto

- Buscar la siguiente línea de código en el archivo install.rdf:
<Description>
<em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
<em:minVersion>1.0</em:minVersion>
<em:maxVersion>3.0a7</em:maxVersion>
</Description>
</em:targetApplication>

- Remplazar el número ubicado entre las etiquetas por la versión actual Firefox instalado. Por ejemplo, voy a cambiar el número 3.0a7 por el número 3.5b4
<em:maxVersion>3.5b4</em:maxVersion>

- Guardar los cambios realizados y comprimir nuevamente todo los archivos
- Asegurarse de poner el mismo nombre al nuevo archivo comprimido
- Cambiar la extensión (.rar, .zip) por la extensión .xpi
- Arrastrar y soltar la extensión modificada al Add-ons manager de Firefox
- Disfrutar de la extensión prefería!
firefox-add-on-install-35-2xie

Un comentario realizado... y tú qué opinas?

Realizar comentario